-fno-stack-protector

valami hasonlo szintu kurvaanyazasnak kene most kovetkeznie, mint amit csutortokon levagtam a gplhuszarkodas miatt. most az ubuntunak sikerult betennie a kaput azzal, h enablaltak az SSP-t a gcc-jukben, mind edgyben, mind feistyben. ennek kovetkezteben a 2.6.16, 2.6.17-es kernelporgeteseim rendbe __stack_chk_fail-lel vegzodott, a xen-3.0.3, -3.0.4 porgeteseim meg vagy valami elborult hibaval doltek el, vagy ugyanugy a kernel doglott meg bennuk. semmi bajom nem lenne amugy ezzel egy qrvara-unstable-branchben, a wikiben viszont aztat irjak, hogy:

“RedHat and gentoo are using SSP by default for years, so we do not expect much breakage potential. So we will build packages with SSP enabled right from the start in Edgy, so that we have much time to discover breakage.”

(afaicr debianban meg redhatban explicite kell specifikalnod h -fstack-protector, h mukodjon). erted, betoljak a stable edgy-be, a testing feisty-be, es kurvara nem erdekli oket, hogy peldaul a kernel se fordul le out-of-the-box, en meg szopjak, amig rajovok, h ez nem bug, ez featura.
kis olvasnivalo:

[1] http://lkml.org/lkml/2006/7/2/67
[2] http://lkml.org/lkml/2006/7/29/27

ugy erzem, hogy egyreszt a pkgmaintainer anyja tragikus hirtelenseggel elhalalozott, masreszt az ezaltal erintettek mennyisegebol patton harmadik hadsereget siman ujra lehetne szervezni. tankostul, tuzersegestul, harcikedvestul.

Leave a Reply